SSL Handshake error
Incident Report for Colect
Resolved
This incident has been resolved.
Posted Jan 22, 2024 - 09:35 CET
Identified
A CDN image server is currently experiencing an expired SSL certificate issue. Our team has identified the problem and is actively working to resolve it.
Posted Jan 22, 2024 - 08:53 CET
This incident affected: Web Brand Portals.